Unix.net.nz

Unix information for NZ

How to setup IPv6 on a Cisco 837 with a static IP address

Since Vodafone NZ do not support IPv6 you will need to setup a static IPv4 address. This is normally done through their business section but residential addresses can get a static IP for about 20 per month.

You will need

  1. Cisco modem / router (I have a 837)
  2. SixxS account
  3. Static IPv6 Address
  4. Assigned IPv6 Address range from SixxS

Residential customers can contact Vodafone NZ on 0800 438 448 or 0800 400 888 for business customers.

I use the SixxS tunnel since they have endpoints for New Zealand.

ipv6 unicast-routing
interface tunnel 0
description IPv6 uplink to SIXXS
no ip address
ipv6 enable
ipv6 nd suppress-ra
ipv6 nd ra suppress
ipv6 address [Your IPv6/64]
ipv6 mtu 1280
tunnel source [Your Public IP]
tunnel destination [IPv4 SixxS endpoint]
tunnel mode ipv6ip
!
ipv6 route 2000::/3 [SixxS Tunnel Endpoint]

The following you will need to add to a IPv6 Firewall

ipv6 access-list IPv6
permit icmp any any unreachable
permit icmp any any packet-too-big
permit icmp any any hop-limit
permit icmp any any reassembly-timeout
permit icmp any any header
permit icmp any any next-header
permit icmp any any parameter-option
permit icmp any any echo-request
permit icmp any any echo-reply
deny icmp any any

Put the rest of your IPv6 Rules

Cisco’s information can be found here and extended information can be found here. You may need to useĀ ipv6 traffic-filter access-list-name {in | out} to set the rule on the interface or Tunnel.

Dont forget you will need to add the following to your IPv4 dialer 0 firewall rule. If you dont you will not be able to connect through the IPv6 Internet.
permit 41 [Sixx IPv4 Tunnel endpoint] any

I hope you find this helpful and gives you enough information to get IPv6 setup on your Cisco router.

Solaris 11 Initial Setup of SMB Server

Isn’t Solaris 11 so different from 10. Changing the way the network is setup and migrating your SMB pools isn’t as easy as you thought it would be. The networking has changed so it is more complex for small biz/home networks. The fact still remains that the ZFS pools aren’t shared like a windows user or admin would expect…

Android compatibility with the SMB programs has improved. It actually works as expected once the pool is upgraded and all steps followed.

Network Setup
Disable the auto configuration
svcadm disable nwam
svcadm enable network/physical:default

Check your current setup
dladm show-phys

dladm show-link
You will notice that the state is unknown since it isnt connected to a logical interface. You can double check that by.
ipadm show-if

ipadm create-if net0
dladm show-link

ipadm create-addr -T dhcp net0/v4
or
ipadm create-addr -t static -a 192.168.1.10/24 net0/v4
ipadm show-addr

netstat -r (Notice the lack of a default route)
route -p add default 192.168.1.1
netstat -r (your route should exist)

If your having trouble
Managing Network Configuration When in Manual Mode
Troubleshooting Interface Configuration

CIFS / SMB Setup
/export/SMB is shared
/export/SMB/othershare is shared as a stand alone share and will not be accessible by the upper level.

Here is what you need to do
pkg install service/file-system/smb
zfs set share=name=mysharename,path=/myshare_pool_path,prot=smb pool
zfs set sharesmb=on pool
svcadm enable -r smb/server
smbadm show-shares computername

smbadm enable-user username

gedit /etc/pam.conf and insert the following at the end.
other password required pam_smb_passwd.so.1 nowarn

enable an existing UNIX user for CIFS sharing (you may have to reset the password again eg.`passwd username` )

Further Resources
CIFS sharing on solaris 11
Managing ZFS File System Changes

Fixing Shares – updated 28/02/2012
List all of the shares
cat /etc/dfs/sharetab
Yuck lots of ~1 and ~2 share lets fix those.
Oracle documentation includes ZFS set -c switch that didn’t work for me.

unshare [-p] [-F FSType] [-o specific_options] [pathname | resourcename]
Example unshare -F smb SHARENAME

DD-WRT QOS, congestion control and vodafone NZ

TCP Vegas is the DD-WRT default setting for the congestion control que. BIC and westwood are also available options.
We had issues with vodafone when we got rate limited to what seemed to be less than dialup speeds. Other users have had issues with TCP Vegas as well on higher latency networks.

CISCO ATM end loop pings are always over 40ms.
QOS disabled results in poor network performance regardless of que options.

Investigate your best option
Set QOS to ignore DNS lookups.
Set QOS to std for HTTP.
Run baseline Speedtest (Speedtest is really good for this since it will keep a record of previous runs).

Change QOS Speeds up for Line
Run Speedtest
Compare results then adjust up or down for better results.
If you aren’t having an issue with the current Que method you may not need to change it. You may want to change it to test if your network behaves better. You will need to monitor how your network is going over a few weeks to notice any changes.